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Introduction

The AT&T Connect® Recording Converter utility lets you convert AT&T Connect recordings (VCM or
VCR) to a standard format. You can convert the recording to a video format (MP4) or extract only
the audio track from the recording and convert it to M4A/WAV.

The Recording Converter comes with six predefined formats (profiles). For example, if you need
your recording to be played on an iPhone® device, you can select the iPhone profile.

The Recording Converter captures the conference’s audio track and the content displayed on the
whiteboard whether it be as a result of application sharing, inserted material, Web tours or
annotations.

The Recording Converter can run as an application with a user interface, or can be invoked from a
command line for bulk conversions.

Note: The Recording Converter doesn’t capture video that was played during a conference,
whether inserted as materials or whether played during a Web tour.

Video size

The video size depends on the original recording size, the content of the recording, and the profile
(destination size)

General rule: The video size is about 1.5-3 times larger than the size of the original recording.

Conversion time

The amount of time needed to convert a recording is a result of the capture time and the video
encoding time.

The capture time is fixed and determined only by the duration of the recording and the playback
acceleration factor (Speed X=4). Since a 4x acceleration factor is normally used, the capture will
take exactly 25% of the recording's duration.

The video encoding time depends mostly on the machine's power. The more powerful the
machine is, the faster it will run the conversion. Roughly, this is 25% of the recording's duration.

General rule: The conversion takes ~50% of the original recording duration.

How do | download the Recording Converter?

1. Go tothe AT&T support site at http://www.corp.att.com/attconnectsupport/downloads/.

2. Click the Recording Converter link and then download the setup package.
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How do | open the Recording Converter?

Click the Windows® Start button and search for the Recording Converter Utility.

What you see

The Recording Converter window is divided into three sections. The first section has buttons for
adding, removing, and converting a file. The second section is a scrollable list of the files that are
being converted. Additional information is provided about the files, including a progress bar. The
third section is for choosing the output folder and format.

-
& AT&T Connect Recording Converter Utility = =
File Convert Help
Add - Rerrm';re G{:nve-rt
i i i ) ry
File Name Last Modified Recording Duration Status
| =
Output Folder:  C:\Connect_Recordings',
Output Format: [MPEG-4 for PC/Mac/iPad (capturing resolution 1024x758) v] 7
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Converting recordings

Adding a recording

1. Inthe Recording Converter, click the Add button, or from the File menu click Add Recording to
open a file-browsing window and select the recording to be converted.

2. Select each of the files that you want to convert and click Open (the file must have a .vcm or
.vcr file name extension). The file name is then displayed in the scrollable list of the Recording
Converter window.

File Name Last Modified Recording Duration  Status 3
Code of Ethics updates.wer S714/2012 3:51 PM  00:40:40 Cane
Intro to new HR portal.ver 571472012 3:51 PM 00:40:40 Done
| Q1 review,ver 5/14/2012 3:51 PM  00:40:40 35%
¥ Sales Plang.ver 5/14/2012 3:51 PM  D0:40:40 0%
¥ week 43 status.vcr 5/14/2012 3:51 PM  00:40:40 0%
=

Converting a recording

1. Inthe Recording Converter window, click the Browse... button to locate the output folder for
the converted file.

2. From the Output Format dropdown list (shown below), choose the desired format (profile).

MPEG-4 for PC/Mac/iPad (capturing resolution 1280x1024)
MPEG-4 for iPhone

MPEG-4 (audio output only)

M4 (audio output only)

WaV (audio output only)

3. From the File List selection column, select the checkbox for each file that you want to convert
and then click the Convert button, or from the Convert menu, click Start Converting.
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Recording formats

& ATAT Connect Recording Converter Utility [ESS
| File Convert .Hefp |
Add Remove Convert
¢ &
File Mame Last Modifved REQDrdlﬂQ Durabon  Status
Code of Ethics updates.yer 5/14/2012 3:51 PM  00:40:40 Cane
| | Intro to new HR portal.wer 5/14/2012 3:51 PM  00:40:40 Done
¥ QL reviewvcr 5/14/2012 3:51 PM  00:40:40 9%
I ~| Sales Plans.ver 5/14/2012 3:51 PM  00:40:40 0%
¥ week 43 status.vcr 5/14/2012 3:51 PM  00:40:40 0%
|
C:latt connect'partidpant\Record\Conversions',
| MPEG-4 for PCMaciPad (captuning resohution 1024768 ?
N Frogress: 47% Stop
l::]_
| )

A progress bar in the Status column of the file list indicates how the conversion is progressing.
When more than one file is converted at a time, a progress bar at the bottom of the window
estimates the combined progress of all the files.

Recording formats

Name Definition

MPEG-4 for PC/Mac/iPad
(capturing resolution
1024x768)

The recording converter utility captures the recording’s whiteboard content at a
resolution of 1024x768, and generates a video file at a resolution of 1024x768.

Use this profile when the entire whiteboard content can be displayed at a
1024x768 resolution without using scrollbars.

MPEG-4 for PC/Mac/iPad
(capturing resolution
1280x1024)

The recording converter utility captures the recording’s whiteboard content at a
1280x1024 resolution and generates a video file at a 1024x768 resolution.

Use this profile when the entire whiteboard content cannot be displayed at a
1024x768 resolution without using scrollbars.

MPEG-4 for iPhone

The recording converter utility captures the Whiteboard content at resolution of
1024x768, and generates a video file at a 480x320 resolution.

Use this profile to produce a video for playback on an iPhone.

MPEG-4 (audio output
only)

Use this profile to produce an audio recording of the AT&T Connect meeting as
an MPEG-4 formatted file.

MA4A (audio output only)

Use this profile to produce an audio recording of the AT&T Connect meeting as
an M4A formatted file.

WAV (audio output only)

Use this profile to produce an audio recording of the AT&T Connect meeting as
a WAV formatted file.
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Stopping the conversion

Stopping the conversion

If you want to stop converting a recording before it is completed, click the Stop button or from the
Convert menu click Stop Converting.

Opening the Output folder window

After converting the recording, you can open the designated output folder window to access the
recording in its new format.

In the Recording Converter, from the File menu, click Open Output Folder. This opens your
designated Output Folder in Windows Explorer.

Best Practices

Once a recording is converted you can upload the recording to a Website from which users can
play the recording using a standard player. To support playing converted recordings on a number
of devices such as a PC or iPhone, you can convert the recording into several formats, and users
can then play the recording in the most suitable format.

The recording converter is a resource-intensive utility that should be run in the best environment
possible—on a strong machine, with a fast I/0 and a minimum number of applications that are
running on the same machine.

Removing a recording

1. From the File List selection column select the checkbox for each recording that you want to
remove and then click the Remove button, or from the File menu, click Remove Recording.
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Removing a recording

i i A o b
" - r -
& AT&T Connect Recording Converter Utility ATTConnectRecConverter | == | J
File Convert Help 1 |
: ° ii Are you sure you want to remove the selected file(s)?
Add Remove Convert
) Yes l ’ Nao ]
File Name La
L
[[1 Code of Ethics updates.ver 5/14f2012 3:51 PM 00:40:40 — | Done
Intro to new HR portal.ver 5/14/2012 3:51 PM  00:40:40 [ | Done
[0 Q1 review.ver 5/14/2012 3:51 PM  00:40:40 [ ] Done
[[] sales Plans.ver 5/14/2012 3:51 PM  00:40:40 [ | Done
[ week 43 status.ver 5/14/2012 3:51 PM  00:40:40 [ ] Done
Output Folder:  C:\att connect\participant\Record\Conversions),
Output Format: [I'-PEG-4 for PC/Mac/iPad {capturing resolution 1024x768) 'l
Converted successfully
Close

L

2. Click Yes when you're asked to confirm that you want to remove the file.
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Using the Command Line to convert a
recording

You can convert one or multiple files in the same directory from the Windows command line—all

in one conversion session.

1. Openthe command line window.
2. Change the directory to:
C:\Users\<username>\AppData\Local\ATT Connect\Participant\Recording Converter

When running the application, information about the conversion progress is displayed on the
“stdout” console. Any error messages or warnings are also displayed to stdout.

| Administrator CAWI system3icmdexe ' A

ng the fFiledz?

Command Line Arguments

The syntax for the command line is:

ATTConnectRecConverterLauncher Zinputdir “directory for batch
conversion” /profile <ProfileNumber> /outputdir output directory

For example:

ATTConnectRecConverterLauncher /inputfile ’c:\temp\ondemand.vcr”
/profile profilel /outputdir * c:\attaconnect”
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Arguments

Arguments

The arguments are case-sensitive.

Argument ‘ Description ‘

/inputfile Specifies the recording file to be converted.

/inputdir Specifies the directory containing multiple .vcr and vem recordings. The conversion utility
processes all recording files in this directory, one at a time, in batch mode.

For batch conversions, the utility will produce an output file with the same name as the
input file, but with a different file extension based on the format being generated.
Disclaimer: Either the input file or the directory can be specified, but not both at the same
time.

/profile Specifies the profile (format) to which the recording files are converted. All files are
converted to the specified format. If no format is specified, uses the first profile.

Joutputdir Specifies the output folder in which the converted files are saved.
If no output folder is specified, the default output folder used is the one defined in the
registry key.

/? Display the following:
Recording converter utility version x.y.xx
USAGE:
/?
Display this help message
/inputfile
Name of recording file to be converted
/inputdir
Name of folder containing the files to be converted
/profile
Profile number (e.g., Profilel) to be used for converting the file(s)
Joutputdir

Name of the folder to contain the converted file(s)
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Reporting problems

If you encounter a technical problem when using the AT&T Connect Recording Converter Utility
you can easily report the problem to AT&T support.

1. To report problems, from the menu bar click Help>Report a Problem.
This opens the Report a Problem dialog box.

F Bl
|, Report a Problem ﬁ

Please enter detailed description of the prablem: FAQ

Before the problem occurred, I was. ..

To see information that will be sent in this report, did here

This report will be sent anonymously.

This submission will not generate a trouble ticket. To follow up,
please contact your helpdesk or AT&T Customer Care. You may be
asked for the report ID below.

Report ID:
t [Send Report ] [ Dont Send ]

=

2. Type in the problem description and click Send Report. You can also click the FAQ link at the
top right hand side of the screen for additional information.

Important: This submission will not generate a trouble ticket. To follow up, please contact your

helpdesk or AT&T Customer Care. You may be asked for the report ID.
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Opening the Log folder

You may wish to view the log of the conversion process. You can include information from the
Logs window when reporting a problem.

To view the Logs window:

e From the File menu, click Open Log Folder. The Logs folder opens in Windows Explorer.
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